Is there NM29?

The official support forum for the browser platform based on Goanna/UXP by roytam1, servicing many Windows 2000/XP users (particularly those on older hardware).

Moderator: roytam1

dkayxdx0
Posts: 40
Joined: 25 Oct 2021, 15:01
Has thanked: 5 times
Been thanked: 3 times
Vietnam

Is there NM29?

Unread post by dkayxdx0 »

I found you only build NM27 and KM-Goana regularly, roytam1. NM28 is more rarely but NM29 seems simply not available. What's wrong with NM29?

User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Is there NM29?

Unread post by K4sum1 »

NM28 is somewhat like a beta build of PM29, it follows the commits to the GitHub repo instead of the browser versions.
I don't know what I'm doing hit album by Brad Sucks

dkayxdx0
Posts: 40
Joined: 25 Oct 2021, 15:01
Has thanked: 5 times
Been thanked: 3 times
Vietnam

Is there NM29?

Unread post by dkayxdx0 »

K4sum1 wrote: 07 Feb 2022, 18:34 NM28 is somewhat like a beta build of PM29, it follows the commits to the GitHub repo instead of the browser versions.
Well, so roytam1 must do something with the version number. The browser (NM28) explicitly refers itself as Pale Moon 28.10.

The addon mTube by RealityRipple doesn't install on NM28 even though it said Pale Moon 28.10 is supported.

Quoted from their site:

Supports Pale Moon [28.7 - 29.*] and SeaMonkey [2.0a1 - 2.*].

https://realityripple.com/Software/Mozilla-Extensions/muTube/

On NM27 he set it to switch to youtube mobile automatically by default. On NM28 he doesn't set this and I don't know how to do this without RealityRipple's mTube addon. youtube.com now is problematic for all versions of Pale Moon, including the latest 29.4.4.

I have to use alternative youtube client like Invidious, works but not very convenient.

https://github.com/mendel5/alternative-front-ends#youtube

https://github.com/iv-org/documentation/blob/master/Invidious-Instances.md

I currently use this public instance of Invidious: https://yewtu.be/feed/popular

roytam1
Local Moderator
Posts: 567
Joined: 28 Jan 2021, 14:42
Been thanked: 473 times
Hong Kong

Is there NM29?

Unread post by roytam1 »

dkayxdx0 wrote: 07 Feb 2022, 08:07 I found you only build NM27 and KM-Goana regularly, roytam1. NM28 is more rarely but NM29 seems simply not available. What's wrong with NM29?
because there is no NM29. NM28 contains most of platform improvements in PM29, but some points in PM29 that's what I don't want, like forcing to use SQLite for NSS databases, changing omni archive format, etc.

dkayxdx0
Posts: 40
Joined: 25 Oct 2021, 15:01
Has thanked: 5 times
Been thanked: 3 times
Vietnam

Is there NM29?

Unread post by dkayxdx0 »

roytam1 wrote: 08 Feb 2022, 09:16
dkayxdx0 wrote: 07 Feb 2022, 08:07 I found you only build NM27 and KM-Goana regularly, roytam1. NM28 is more rarely but NM29 seems simply not available. What's wrong with NM29?
because there is no NM29. NM28 contains most of platform improvements in PM29, but some points in PM29 that's what I don't want, like forcing to use SQLite for NSS databases, changing omni archive format, etc.
The problem is why don't addons installed correctly even though they support Pale Moon 28.10? NM refers itself as Pale Moon 28.10, but the mTube addon I mentioned above and many addons on Pale Moon addons site can't be installed. They all said the browser is not supported.

I have to visit github.com regularly, but JustOff's addon for github can't be installed on NM28. I tried many previous versions, still said the browser is not supported.

https://github.com/JustOff/github-wc-polyfill

dkayxdx0
Posts: 40
Joined: 25 Oct 2021, 15:01
Has thanked: 5 times
Been thanked: 3 times
Vietnam

Is there NM29?

Unread post by dkayxdx0 »

If NM28 is basically Pale Moon 29 then what about making it possible to install Pale Moon 29 only addons? Many addons recently added on the Pale Moon addons site only support Pale Moon 29.

roytam1
Local Moderator
Posts: 567
Joined: 28 Jan 2021, 14:42
Been thanked: 473 times
Hong Kong

Is there NM29?

Unread post by roytam1 »

dkayxdx0 wrote: 08 Feb 2022, 11:35
roytam1 wrote: 08 Feb 2022, 09:16
dkayxdx0 wrote: 07 Feb 2022, 08:07 I found you only build NM27 and KM-Goana regularly, roytam1. NM28 is more rarely but NM29 seems simply not available. What's wrong with NM29?
because there is no NM29. NM28 contains most of platform improvements in PM29, but some points in PM29 that's what I don't want, like forcing to use SQLite for NSS databases, changing omni archive format, etc.
The problem is why don't addons installed correctly even though they support Pale Moon 28.10? NM refers itself as Pale Moon 28.10, but the mTube addon I mentioned above and many addons on Pale Moon addons site can't be installed. They all said the browser is not supported.

I have to visit github.com regularly, but JustOff's addon for github can't be installed on NM28. I tried many previous versions, still said the browser is not supported.

https://github.com/JustOff/github-wc-polyfill
you can download xpi and modify minversion to 28.10 and repack and install.

dkayxdx0
Posts: 40
Joined: 25 Oct 2021, 15:01
Has thanked: 5 times
Been thanked: 3 times
Vietnam

Is there NM29?

Unread post by dkayxdx0 »

roytam1 wrote: 08 Feb 2022, 13:11
dkayxdx0 wrote: 08 Feb 2022, 11:35
roytam1 wrote: 08 Feb 2022, 09:16

because there is no NM29. NM28 contains most of platform improvements in PM29, but some points in PM29 that's what I don't want, like forcing to use SQLite for NSS databases, changing omni archive format, etc.
The problem is why don't addons installed correctly even though they support Pale Moon 28.10? NM refers itself as Pale Moon 28.10, but the mTube addon I mentioned above and many addons on Pale Moon addons site can't be installed. They all said the browser is not supported.

I have to visit github.com regularly, but JustOff's addon for github can't be installed on NM28. I tried many previous versions, still said the browser is not supported.

https://github.com/JustOff/github-wc-polyfill
you can download xpi and modify minversion to 28.10 and repack and install.
If having to going through all of this hassles like what happened when Pale Moon decided to dump the old Firefox GUID, I would rather give up. Keep in mind the addon I mentioned is only an example, there are many others. Doing the modify minversion and repack trick is also stopped the addons from auto updating. So many troubles. Not worth to try.

roytam1
Local Moderator
Posts: 567
Joined: 28 Jan 2021, 14:42
Been thanked: 473 times
Hong Kong

Is there NM29?

Unread post by roytam1 »

dkayxdx0 wrote: 09 Feb 2022, 05:17
roytam1 wrote: 08 Feb 2022, 13:11
dkayxdx0 wrote: 08 Feb 2022, 11:35

The problem is why don't addons installed correctly even though they support Pale Moon 28.10? NM refers itself as Pale Moon 28.10, but the mTube addon I mentioned above and many addons on Pale Moon addons site can't be installed. They all said the browser is not supported.

I have to visit github.com regularly, but JustOff's addon for github can't be installed on NM28. I tried many previous versions, still said the browser is not supported.

https://github.com/JustOff/github-wc-polyfill
you can download xpi and modify minversion to 28.10 and repack and install.
If having to going through all of this hassles like what happened when Pale Moon decided to dump the old Firefox GUID, I would rather give up. Keep in mind the addon I mentioned is only an example, there are many others. Doing the modify minversion and repack trick is also stopped the addons from auto updating. So many troubles. Not worth to try.
there is no way to pretend official version for auto-update since NM28 is already derailed from their side, and I don't want people think it is the same as official 29 version (while it is not in many ways).

dkayxdx0
Posts: 40
Joined: 25 Oct 2021, 15:01
Has thanked: 5 times
Been thanked: 3 times
Vietnam

Is there NM29?

Unread post by dkayxdx0 »

roytam1 wrote: 09 Feb 2022, 06:57 there is no way to pretend official version for auto-update since NM28 is already derailed from their side, and I don't want people think it is the same as official 29 version (while it is not in many ways).
Yeah. So you forked Pale Moon 28 and become the upstream after they dropped the 28.x series. BTW, I can't find New Moon 28 repo on your github. I only see palemoon27 and palemoon26 but no palemoon28. Is the code for New Moon 28 public? If it's so, how to get it? Thanks.

roytam1
Local Moderator
Posts: 567
Joined: 28 Jan 2021, 14:42
Been thanked: 473 times
Hong Kong

Is there NM29?

Unread post by roytam1 »

dkayxdx0 wrote: 09 Feb 2022, 14:37
roytam1 wrote: 09 Feb 2022, 06:57 there is no way to pretend official version for auto-update since NM28 is already derailed from their side, and I don't want people think it is the same as official 29 version (while it is not in many ways).
Yeah. So you forked Pale Moon 28 and become the upstream after they dropped the 28.x series. BTW, I can't find New Moon 28 repo on your github. I only see palemoon27 and palemoon26 but no palemoon28. Is the code for New Moon 28 public? If it's so, how to get it? Thanks.
it is in https://github.com/roytam1/UXP/tree/custom

User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Is there NM29?

Unread post by K4sum1 »

@roytam1 You could try doing what Waterfox Classic does, where it installs any addon no matter what version of Firefox it calls for.
I don't know what I'm doing hit album by Brad Sucks

roytam1
Local Moderator
Posts: 567
Joined: 28 Jan 2021, 14:42
Been thanked: 473 times
Hong Kong

Is there NM29?

Unread post by roytam1 »

K4sum1 wrote: 09 Feb 2022, 19:36 @roytam1 You could try doing what Waterfox Classic does, where it installs any addon no matter what version of Firefox it calls for.
you can turn off version check in about:config or using moon tester tools.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests