Windows NT 6.x Builds With The Wrong Visual Styles

See the evolution of one Windows version into another.
User avatar
SkyeWeeb
Posts: 41
Joined: 05 Jun 2021, 06:45
Location: Earth
Been thanked: 18 times
Contact:
United States of America

Windows NT 6.x Builds With The Wrong Visual Styles

Unread post by SkyeWeeb »

Every build of Windows from Windows 8 build 8400 (the Release Preview) to Windows 10 build 9926 is compatible with the themes of the builds before it. What do I mean by this? Under Windows 8 RTM (9200), you can run 8400's theme natively along with the default. Under 8.1, any theme for 8.0 and 8400 can load. Same goes for early 10 builds. Under 9841, any Windows 8.1, 8.0, and 8400 visual style runs without many issues. This seemed to stop around 9926 due to the visual style engine changing, I assume. Here's three versions of aero.msstyles running under 9926 with no issues. (8400, 9600, and 9841 respectively)

Image
Image
Image

If you patch uxtheme, you can run any 8.x visual style under 9926, but the caption buttons will be huge due to it being Windows 10, and most of the taskbar textures being missing due to msstyles losing the ability to skin the taskbar as well. Here's Simplex's Windows 7 Aero visual style also running under 9926.

Image

And I will reiterate, this will also work with any version of Windows between 8400 and 9926, but you can not use themes newer than the OS you're using. (i.e. 9841's aero.msstyles under 8400) And if there are builds before 8400 and after 9926 that also work with this, please correct me.
Last edited by SkyeWeeb on 13 Jun 2021, 07:12, edited 1 time in total.
19 year old dumbass.

User avatar
K4sum1
Lazy Owner
Posts: 920
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 583 times
Been thanked: 271 times
Contact:
United States of America

Windows 8.x and Early Windows 10 Builds With The Wrong Visual Styles

Unread post by K4sum1 »

I would like someone to port Simplex's theme to properly work on 8.0, or at least have a good 8.0 Windows 7 style theme.

More on topic is that the 8400 theme has issues with task manager on 9200, which is why I use a custom CP theme, although I would more prefer a Windows 7 theme with the CP frames, and a taskbar with the CP frame texture.
I don't know what I'm doing hit album by Brad Sucks

User avatar
SkyeWeeb
Posts: 41
Joined: 05 Jun 2021, 06:45
Location: Earth
Been thanked: 18 times
Contact:
United States of America

Windows 8.x and Early Windows 10 Builds With The Wrong Visual Styles

Unread post by SkyeWeeb »

The native 8400 theme is pretty buggy on anything that isn't 8400 anyway. If I use 8.1, I either use Simplex's 7 Aero theme or a custom Consumer Preview theme. None of these combos are perfect at all, it's just strange it worked for so long.

Fun fact: This same thing happens with 7 beta builds as well, I might make a new thread with that some time down the road.
19 year old dumbass.

User avatar
SkyeWeeb
Posts: 41
Joined: 05 Jun 2021, 06:45
Location: Earth
Been thanked: 18 times
Contact:
United States of America

Windows 8.x and Early Windows 10 Builds With The Wrong Visual Styles

Unread post by SkyeWeeb »

SkyeWeeb wrote: 07 Jun 2021, 07:25 Fun fact: This same thing happens with 7 beta builds as well, I might make a new thread with that some time down the road.
Imagine making a useless new thread for this, I'll just post them here. Unlike 8.x and 10, these mostly work both ways, and with beta builds. Mix and match them if you can and see what cursed goodness you can get.

6801 VS under 7601:
Image

7000 VS under 6002:
Image

6608 VS under 7601:
Image

7000 VS under 6608:
Image

7601 VS under 6608: (i think)
Image

6608 VS under 6801:
Image

7000 VS under 6801:
Image
19 year old dumbass.

User avatar
Moline
Posts: 100
Joined: 18 May 2021, 20:06
Has thanked: 12 times
Been thanked: 12 times
Contact:
United States of America

Windows NT 6.x Builds With The Wrong Visual Styles

Unread post by Moline »

Any theme from Windows 8 builds earlier than 8400 (E.G. Windows 8 Build 8277) does not work. After applying the theme, you get a black screen (even with the lock screen disabled), requiring you to load up a Windows 8 USB and use System Restore from it to get it working again. Simply deleting the theme files from another version of Windows does not work apparently. If you don't have a restore point, most likely you will have to use Reset This PC.

The 8400 Theme works nicely on 8.1. No bugs and I did not have to patch anything.
View my computers here. If you also need Windows help, get it here as well: http://windowsenthusiasts1.epizy.com/

User avatar
SkyeWeeb
Posts: 41
Joined: 05 Jun 2021, 06:45
Location: Earth
Been thanked: 18 times
Contact:
United States of America

Windows NT 6.x Builds With The Wrong Visual Styles

Unread post by SkyeWeeb »

Moline wrote: 30 Jun 2021, 14:40 Any theme from Windows 8 builds earlier than 8400 (E.G. Windows 8 Build 8277) does not work. After applying the theme, you get a black screen (even with the lock screen disabled), requiring you to load up a Windows 8 USB and use System Restore from it to get it working again. Simply deleting the theme files from another version of Windows does not work apparently. If you don't have a restore point, most likely you will have to use Reset This PC.

The 8400 Theme works nicely on 8.1. No bugs and I did not have to patch anything.
That's kinda why I only mentioned 8400. I should also mention that any 8 build's visual style can work under 7 with modifications, as long as you're willing to give up DWM. The taskbar is proof of the visual style change, along with middle captions strangely.
19 year old dumbass.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests