Issues with certain email providers not receiving emails from Eclipse

Important announcements and guidelines.
User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by K4sum1 »

Working:
astolfo.email (tested by Niko)
cock.li (tested by me, Niko, and prints)
Disroot (tested by Niko)
HEY (tested by sladewatkins)
int.pl (tested by Niko)
IONOS (tested by XP Luna)
Posteo (tested by Niko)
Spaces (tested by notterra)

Proton Mail (tested by aeoe and XP-x64-Lover) (No direct link since honeypot)
Tutanota (tested by Niko) (No direct link since honeypot)
Yahoo (tested by Darth Agnon, dvincent, and Tyorgg) (No direct link since big company willing to sell data)

So far I have been able to fix the issues with these, however I do not recommend them due to having this issue in the first place:
FORTHnet (tested by GoodConcscience)
Horizon Mail (tested by Niko)
Gmail
GMX/Mail.com (tested by me and OCCiera)
Vivaldi Mail (tested by Niko)

Broken:
Hotmail
iCloud
Outlook
Yandex?

Edit: Server IP appears to be on Proofpoint blacklist, so email services that don't use Proofpoint should work. Added a bunch more services that failed to send in mass email.

Edit 2: I have gotten emails sending to Gmail, GMX, and more. The below will be left for historical purposes.

I've noticed recently that emails going to GMX addresses never get received and there's no error or rejection email sent to Eclipse. Gmail on the other hand said today that they've blacklisted the IP of the Eclipse server. I don't know why this is happening. I don't know what they have to gain by blocking Eclipse. Maybe old enemies are still angry and made it happen. I don't know.

I've only been able to test one other email service and that is cock.li. The name may be funny, but it's one of the few free email services I would actually trust. Not run by some big company or corporation hungry for your data. They still receive emails from Eclipse just fine.

So far sample size of three showing the bigger email services blocking Eclipse. I don't know what happened or what I would've done for this to occur. I don't think Eclipse is big enough for them to collude or has done anything. I don't know what the reason is for this.
I don't know what I'm doing hit album by Brad Sucks

User avatar
prints
Posts: 17
Joined: 24 Apr 2023, 18:14
Mood: Protective
OS: Microsoft Windows XP
Has thanked: 4 times
Been thanked: 6 times
Contact:
Japan

Issues with certain email providers not receiving emails from Eclipse

Unread post by prints »

I received the E-mail, @cock.li

User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by K4sum1 »

So the email sending process gave me more services that don't work. Eclipse seems to be on a Proofpoint blacklist. I have no idea how this could have happened, but I'm leaning towards old enemies somehow got this to happen. So lots of email services just don't work with Eclipse anymore.
I don't know what I'm doing hit album by Brad Sucks

User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by K4sum1 »

Due to a configuration error some services were rejecting emails from Eclipse. I do believe I've fixed it. Sending another test email to see what services accept it.
I don't know what I'm doing hit album by Brad Sucks

User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by K4sum1 »

AnonAddy, Riseup, Tutanota, and VWebR seem to be working now. Or at least sending wasn't immediately rejected. Removed from not working list, but will wait for someone with an address from one of these to report back before adding to working list.
I don't know what I'm doing hit album by Brad Sucks

User avatar
XP Luna
Posts: 115
Joined: 01 Feb 2021, 14:57
Has thanked: 14 times
Been thanked: 20 times
Germany

Issues with certain email providers not receiving emails from Eclipse

Unread post by XP Luna »

Received it, my provider is IONOS.
XP Luna

User avatar
prints
Posts: 17
Joined: 24 Apr 2023, 18:14
Mood: Protective
OS: Microsoft Windows XP
Has thanked: 4 times
Been thanked: 6 times
Contact:
Japan

Issues with certain email providers not receiving emails from Eclipse

Unread post by prints »

the second one got spam filtered believe it or not, again on cock.li

User avatar
Darth Agnon
Posts: 10
Joined: 12 Feb 2023, 20:25
OS: Windows 7
Has thanked: 11 times
Been thanked: 6 times
Contact:
Great Britain

Issues with certain email providers not receiving emails from Eclipse

Unread post by Darth Agnon »

Received email, yahoo.co.uk

Self-hosted/independent email servers are commonly blacklisted instantly by all the major players, one of the reasons I've seen many people counselling against hosting one's own email server.

User avatar
Tyorgg
Posts: 1
Joined: 24 Oct 2021, 17:15
Has thanked: 2 times
Been thanked: 1 time
Italy

Issues with certain email providers not receiving emails from Eclipse

Unread post by Tyorgg »

Yahoo.com is working! My @ is rocketmail.com

User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by K4sum1 »

I tested a lot of services with help from Niko. I didn't do it through Eclipse as in the forum, instead I sent them using CLI email client on server. I assume these would give the same results as a real user on the forum.
I don't know what I'm doing hit album by Brad Sucks

notterra
Posts: 1
Joined: 21 Mar 2023, 20:10
OS: Debian11/arm32
Been thanked: 1 time
Moldova

Issues with certain email providers not receiving emails from Eclipse

Unread post by notterra »

I've recieved the email, @spaces.im

User avatar
XP-x64-Lover
Posts: 1
Joined: 25 Feb 2021, 17:21
Location: Planet Earth.
Has thanked: 2 times
Been thanked: 1 time

Issues with certain email providers not receiving emails from Eclipse

Unread post by XP-x64-Lover »

Yes, I got the Email. (Protonmail)
Hardcore XP x64 Enthusiast

User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by K4sum1 »

So I have gotten Gmail and GMX working now. I can't test any other services just yet. Will send out another mass email and see what happens.
I don't know what I'm doing hit album by Brad Sucks

User avatar
prints
Posts: 17
Joined: 24 Apr 2023, 18:14
Mood: Protective
OS: Microsoft Windows XP
Has thanked: 4 times
Been thanked: 6 times
Contact:
Japan

Issues with certain email providers not receiving emails from Eclipse

Unread post by prints »

E-mail #3 has been received (@cock.li)

dvincent
Posts: 1
Joined: 10 Dec 2023, 03:24
OS: Windows 7
Been thanked: 1 time
France

Issues with certain email providers not receiving emails from Eclipse

Unread post by dvincent »

Thx a lot !
my email in yahoo.fr is working very well
Keep up the good job !

User avatar
Nanandmic567
Posts: 6
Joined: 05 Feb 2021, 09:54
Location: Phrapradang, Samutprakan
Has thanked: 3 times
Been thanked: 3 times
Contact:
Thailand

Issues with certain email providers not receiving emails from Eclipse

Unread post by Nanandmic567 »

I've just received email recently..
And it's Gmail. (Which is working just fine)

GoodConcscience
Posts: 1
Joined: 07 Nov 2021, 02:25
Been thanked: 1 time
Greece

Issues with certain email providers not receiving emails from Eclipse

Unread post by GoodConcscience »

Hi :)

Today I did receive two e-mails from eclipse.cx, in fact it's one identical e-mail just sent twice; the first copy was received on 202403090357UTC, the second just 8min later, 202403090405UTC ;) ...

I don't use one of the popular web mail services, instead I use the e-mail service provided by my ISP: @the.forthnet.gr
Hope this info is of good use to the webmaster(s) 8-) ...

Greetings.

User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by K4sum1 »

GoodConcscience wrote: 09 Mar 2024, 19:18 Today I did receive two e-mails from eclipse.cx, in fact it's one identical e-mail just sent twice; the first copy was received on 202403090357UTC, the second just 8min later, 202403090405UTC ;) ...
Yeah I accidentally canceled the first email sending script so it didn't get fully sent to everyone. The wording is so confusing. I think it was from me closing tab early idk.
I don't know what I'm doing hit album by Brad Sucks

User avatar
sladewatkins
Posts: 1
Joined: 15 Sep 2023, 01:11
OS: macOS arm64/Win64bit
Been thanked: 1 time
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by sladewatkins »

Hi, HEY.com works (at least on HEY for Domains), but is flagged as spam. Since both HEY for You and HEY for Domains use the same spam filter, I'd assume it's the same for both.

User avatar
OCCiera
Posts: 20
Joined: 02 Sep 2023, 05:50
OS: Windows Vista/7 x64
Has thanked: 14 times
Been thanked: 7 times
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by OCCiera »

2 copies of email 3 received, provider is @mail.com
Image

User avatar
kloak
Banned
Posts: 29
Joined: 14 Jul 2024, 17:46
Location: Annoying K4sum1
OS: Windows XP x86
Has thanked: 1 time
Contact:
Israel

Issues with certain email providers not receiving emails from Eclipse

Unread post by kloak »

GMX goes to spam-folder but does work

Seems like your webhost isn't particularly well-reputed in terms of handling abuse reports (hostpapa). Unfortunately proper email handling is painful these days due to mass ipv4 abuse everywhere and old spamfilters etc so yknow.

Also, read this (and maybe even this, this and especially this).
former admin, now here just to annoy the lazy owner into actually doing shit

User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by K4sum1 »

kloak wrote: 15 Jul 2024, 17:44 GMX goes to spam-folder but does work
Average big email provider spam detection system moment.
kloak wrote: 15 Jul 2024, 17:44 Seems like your webhost isn't particularly well-reputed in terms of handling abuse reports (hostpapa). Unfortunately proper email handling is painful these days due to mass ipv4 abuse everywhere and old spamfilters etc so yknow.
I don't have hosting from HostPapa?
kloak wrote: 15 Jul 2024, 17:44 Also, read this (and maybe even this, this and especially this).
lazy
I don't know what I'm doing hit album by Brad Sucks

User avatar
kloak
Banned
Posts: 29
Joined: 14 Jul 2024, 17:46
Location: Annoying K4sum1
OS: Windows XP x86
Has thanked: 1 time
Contact:
Israel

Issues with certain email providers not receiving emails from Eclipse

Unread post by kloak »

K4sum1 wrote: 15 Jul 2024, 18:21 I don't have hosting from HostPapa?
According to a quick ping and ip lookup your server's host resolves there: https://ipinfo.io/198.46.203.136

Guessing whatever host you're using now is using their infrastructure.
former admin, now here just to annoy the lazy owner into actually doing shit

User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by K4sum1 »

Huh, interesting, didn't know that.

On a somewhat related note, I have been getting phishing emails from scammers pretending to be HostPapa, and it confused the fuck out of me since I didn't know the servers were from them.
I don't know what I'm doing hit album by Brad Sucks

User avatar
kloak
Banned
Posts: 29
Joined: 14 Jul 2024, 17:46
Location: Annoying K4sum1
OS: Windows XP x86
Has thanked: 1 time
Contact:
Israel

Issues with certain email providers not receiving emails from Eclipse

Unread post by kloak »

Well, I guess that answers things now.

Maybe look into offloading your email onto a 3rd party service if this continue to be a problem, though this can get costly if you're server is sending lot's of mail a day through mail(). I guess there's a way of checking server logs and making a rough average of the daily mail count, probably in linux terminal rathe than php bb panel.

All for a lack of 'not going to the spam filter' too on a small website feels a little bit pointless, but also not if you need proper correspondance on your actual mail when sending for serious things, too, since I'm aware you use an email on the server for various other personal duties too
former admin, now here just to annoy the lazy owner into actually doing shit

User avatar
K4sum1
Lazy Owner
Posts: 957
Joined: 11 Jan 2021, 07:40
Location: ur dads house
OS: Windows 8.1 x64
Has thanked: 613 times
Been thanked: 280 times
Contact:
United States of America

Issues with certain email providers not receiving emails from Eclipse

Unread post by K4sum1 »

kloak wrote: 16 Jul 2024, 14:47 since I'm aware you use an email on the server for various other personal duties too
Not anymore lol

*@eclipse.cx gets forwarded to k4sum1@airmail.cc

I can't exactly send email unless I log into the server and use cli to do it.
I don't know what I'm doing hit album by Brad Sucks

User avatar
kloak
Banned
Posts: 29
Joined: 14 Jul 2024, 17:46
Location: Annoying K4sum1
OS: Windows XP x86
Has thanked: 1 time
Contact:
Israel

Issues with certain email providers not receiving emails from Eclipse

Unread post by kloak »

dovecot+postfix+outlook 2002=epic win
former admin, now here just to annoy the lazy owner into actually doing shit

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests